1 2 3 4 5 6

Vulnerabilidades rss pdf

Coordinación de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2005-325 Actualización de Ubuntu para Gaim.

Ubuntu liberó una actualización para Gaim. Esta repara una vulnerabilidad y dos debilidades que pueden explotarse para ocasionar una negación de servicio (DoS) o comprometer el sistema de un usuario.

  • Fecha de Liberación: 12-Ago-2005
  • Fuente:

    Ubuntu Security Notice
    USN-168-1

  • CVE ID: CAN-2005-2102 CAN-2005-2103 CAN-2005-2370
  • Riesgo Altamente crítico
  • Problema de Vulnerabilidad Remoto
  • Tipo de Vulnerabilidad Buffer overflow

Sistemas Afectados

Ubuntu Linux 4.10 gaim 1.0.0-1ubuntu1.8
Ubuntu Linux 5.04 gaim 1.1.4-1ubuntu4.4
  1. Descripción

    Ubuntu liberó una actualización para Gaim. Esta repara una vulnerabilidad y dos debilidades que pueden explotarse por personas maliciosas para ocasionar una negación de servicio (DoS) o comprometer el sistema de un usuario.

    • Un error en el manejo de los mensajes entrantes puede explotarse para ocasionar un desbordamiento de memoria de heap al enviar un mensaje malicioso a un usuario que este utilizando AIM o ICQ, permitiendo la ejecución de código arbitrario.

    • Un error en el manejo de la transferencia de archivos puede explotarse para tirar la aplicación al intentar enviar un archivo malicioso (No cumpla con UTF8) a un usuario que este utilizando AIM o ICQ.

      Ver:
      Vulnerabilidad de Buffer Overflow y Negación de servicio en Gaim.

    • Un error de alineación de memoria dentro de la librería Gadu, de la cuál Gaim tiene una copia del código vulnerable, puede explotarse para tirar la aplicación.

  2. Impacto

    Negación de servicio (DoS).

    Acceso al sistema.

  3. Solución

    Aplicar los paquetes actualizados.

    -- Ubuntu 4.10 (Warty Warthog) --

    Archivos fuente:

    http://security.ubuntu.com/ubuntu/pool/main/g/gaim/gaim_1.0.0-1ubuntu1.8.diff.gz
    Size/MD5: 49554 19d8f02e32c2bfbb781961bc4b29b6c6
    http://security.ubuntu.com/ubuntu/pool/main/g/gaim/gaim_1.0.0-1ubuntu1.8.dsc
    Size/MD5: 853 07f788c5d240af40778e4b84a280b7e8
    http://security.ubuntu.com/ubuntu/pool/main/g/gaim/gaim_1.0.0.orig.tar.gz
    MD5: 6985979 7dde686aace751a49dce734fd0cb7ace

    -- Ubuntu 5.04 (Hoary Hedgehog) --

    Archivos fuente:

    http://security.ubuntu.com/ubuntu/pool/main/g/gaim/gaim_1.1.4-1ubuntu4.4.diff.gz
    MD5: 109435 fbb5c0bb0acf56ae1b30b883d434091a
    http://security.ubuntu.com/ubuntu/pool/main/g/gaim/gaim_1.1.4-1ubuntu4.4.dsc
    MD5: 991 231442b5411b0b85206a8c11072eb938
    http://security.ubuntu.com/ubuntu/pool/main/g/gaim/gaim_1.1.4.orig.tar.gz
    MD5: 5188552 b55bf3217b271918384f3f015a6e5b62

  4. Apéndices

    Mayor información.

    http://www.ubuntulinux.org/
    http://www.seguridad.unam.mx/vulnerabilidades/

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Floriberto López Velázquez (flopez at seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Coordinación de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México Aviso legal |  Créditos |  Staff |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT