1 2 3 4 5 6

Vulnerabilidades rss pdf

Coordinación de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2005-433 Múltiples vulnerabilidades en phpMyFAQ

Se reportarón varias vulnerabilidades en phpMyFAQ, que pueden explotarse para realizar ataques de Cross-site Scripting e inyección SQL, mostrar información sensible, y comprometer un sistema vulnerable.

  • Fecha de Liberación: 26-Sep-2005
  • Ultima Revisión: 26-Sep-2005
  • Fuente:

    rgod y phpMyFAQ Security Advisory
    2005-09-23

  • Riesgo Altamente crítico
  • Problema de Vulnerabilidad Remoto
  • Tipo de Vulnerabilidad Verificación deficiente en parametros

Sistemas Afectados

phpMyFAQ 1.5.2
  1. Descripción

    rgod reportó varias vulnerabilidades en phpMyFAQ, que pueden explotarse por personas maliciosas para realizar ataques de Cross-site Scripting e inyección SQL, mostrar información sensible, y comprometer un sistema vulnerable.

    1. La entrada que se pasa al parámetro "username" dentro de "password.php" cuando se utiliza la funcionalidad password olvidado no es verificada apropiadamente antes de utilizarse en una petición SQL. Esto puede explotarse para manipular peticiones SQL inyectando código SQL arbitrario.

      Una explotación exitosa requiere que "magic_quotes_gpc" este deshabilitado.

    2. La entrada que se pasa al parámetro "PMF_CONF[version]" dentro de "footer.php" y al parámetro "PMF_LANG[metaLanguage]" dentro de "header.php" no es verificada apropiadamente antes de regresarse al usuario. Esto puede explotarse para ejecutar código HTML y script arbitrarios dentro de la sesión de un usuario en el contexto de un sitio vulnerable.

    3. La entrada que se pasa al parámetro "LANGCODE" dentro de "index.php" no es verificada apropiadamente antes de incluir archivos. Esto puede explotarse para agregar archivos de fuentes locales y externas.

      Además puede explotarse para ejecutar código PHP arbitrario al incluir archivos grandes con código PHP inyectado via la cabecera HTTP "User-Agent".

      Una explotación exitosa requiere que "magic_quotes_gpc" este deshabilitado.

    4. El problema esta en que archivos grandes son colocados de forma insegura en el directorio raíz de Web. Esto puede explotarse para mostrar información de usuarios.

    Las vulnerabilidades fuerón confirmadas en la versión 1.5.1. Versiones anteriores también podrián ser afectadas.

  2. Impacto

    Cross-site Scripting.

    Manipulación de datos.

    Exposición de información del sistema.

    Exposición de información sensible.

    Acceso al sistema.

  3. Solución

    Actualizar a la versión 1.5.2
    http://www.phpmyfaq.de/download.php

  4. Apéndices

    Mayor información.

    http://www.phpmyfaq.de/advisory_2005-09-23.php

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Floriberto López Velázquez (flopez at seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Coordinación de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México Aviso legal |  Créditos |  Staff |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT