1 2 3 4 5 6

Vulnerabilidades rss pdf

Coordinación de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2005-488 RedHat liberó una actualización para Lynx.

RedHat liberó una actualización para Lynx. Esta repara una vulnerabilidad que puede explotarse para comprometer el sistema de un usuario.

  • Fecha de Liberación: 17-Oct-2005
  • Ultima Revisión: 17-Oct-2005
  • Fuente:

    Red Hat Security Advisory
    RHSA-2005:803-01

  • CVE ID: CAN-2005-3120
  • Riesgo Altamente crítico
  • Problema de Vulnerabilidad Remoto
  • Tipo de Vulnerabilidad Buffer overflow

Sistemas Afectados

RedHat Enterprise Linux AS 2.1 Lynx 2.8.4-18
RedHat Enterprise Linux AS 3 Lynx 2.8.5-11
RedHat Enterprise Linux AS 4 Lynx 2.8.5-18
RedHat Enterprise Linux ES 2.1 Lynx 2.8.4-18
RedHat Enterprise Linux ES 3 Lynx 2.8.5-11
RedHat Enterprise Linux ES 4 Lynx 2.8.5-18
RedHat Enterprise Linux WS 2.1 Lynx 2.8.4-18
RedHat Enterprise Linux WS 3 Lynx 2.8.5-11
RedHat Enterprise Linux WS 4 Lynx 2.8.5-18
  1. Descripción

    RedHat liberó una actualización para Lynx. Esta repara una vulnerabilidad que puede explotarse por personas maliciosas para comprometer el sistema de un usuario.

    • Si se utiliza una URL NNTP, Lynx se conecta a un servidor NNTP y recupera información sobre artículos disponibles en el grupo de noticias seleccionado. Ulf Harnhammar encontró un desbordamiento de memoria en la función que maneja el escape de caracteres especiales. Un atacante podría levantar un servidor NNTP malicioso y engañar a un usuario para que lo accese utilizando Lynx. Los datos que entregue el servidor podrían activar el desbordamiento y ejecutar código arbitrario con los derechos del usuario que este utilizando Lynx.

      Ver:
      Buffer Overflow en 'HTrjis()' de Lynx.
      http://www.seguridad.unam.mx/vulnerabilidadesDB/?vulne=4848

  2. Impacto

    Acceso al sistema.

  3. Solución

    Aplicar los paquetes actualizados.

    Los paquetes actualizados estan disponibles en el sitio de RedHat
    http://rhn.redhat.com/

    Red Hat Enterprise Linux AS (Advanced Server) version 2.1:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/2.1AS/en/os/SRPMS/lynx-2.8.4-18.1.1.src.rpm
    60a69f80b73d527c0245b4ed65a5cbb7 lynx-2.8.4-18.1.1.src.rpm
    
    i386:
    0d17fa55fcb0d090b95b70aee84b9d32 lynx-2.8.4-18.1.1.i386.rpm
    
    ia64:
    c6bf49b71290710e76a3e188d45a5c96 lynx-2.8.4-18.1.1.ia64.rpm
    
    
    Red Hat Linux Advanced Workstation 2.1:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/2.1AW/en/os/SRPMS/lynx-2.8.4-18.1.1.src.rpm
    60a69f80b73d527c0245b4ed65a5cbb7 lynx-2.8.4-18.1.1.src.rpm
    
    ia64:
    c6bf49b71290710e76a3e188d45a5c96 lynx-2.8.4-18.1.1.ia64.rpm
    
    
    Red Hat Enterprise Linux ES version 2.1:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/2.1ES/en/os/SRPMS/lynx-2.8.4-18.1.1.src.rpm
    60a69f80b73d527c0245b4ed65a5cbb7 lynx-2.8.4-18.1.1.src.rpm
    
    i386:
    0d17fa55fcb0d090b95b70aee84b9d32 lynx-2.8.4-18.1.1.i386.rpm
    
    
    Red Hat Enterprise Linux WS version 2.1:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/2.1WS/en/os/SRPMS/lynx-2.8.4-18.1.1.src.rpm
    60a69f80b73d527c0245b4ed65a5cbb7 lynx-2.8.4-18.1.1.src.rpm
    
    i386:
    0d17fa55fcb0d090b95b70aee84b9d32 lynx-2.8.4-18.1.1.i386.rpm
    
    
    Red Hat Enterprise Linux AS version 3:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/3AS/en/os/SRPMS/lynx-2.8.5-11.1.src.rpm
    ca0e6cecdbe5d962ba2e0e25906f06c3 lynx-2.8.5-11.1.src.rpm
    
    i386:
    4fbf85314f748e70d688d4ef9f1ff039 lynx-2.8.5-11.1.i386.rpm
    
    ia64:
    78719dbe540537935c8ff0580a2e0d81 lynx-2.8.5-11.1.ia64.rpm
    
    ppc:
    f2eac36b447292abc662862220bfb06a lynx-2.8.5-11.1.ppc.rpm
    
    s390:
    0a54265e85c70269d716143f516ba4c8 lynx-2.8.5-11.1.s390.rpm
    
    s390x:
    e6954205d07620602060a637f256427b lynx-2.8.5-11.1.s390x.rpm
    
    x86_64:
    d5b28eee28b96bfc485c931bc70f6c8a lynx-2.8.5-11.1.x86_64.rpm
    
    
    Red Hat Desktop version 3:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/3desktop/en/os/SRPMS/lynx-2.8.5-11.1.src.rpm
    ca0e6cecdbe5d962ba2e0e25906f06c3 lynx-2.8.5-11.1.src.rpm
    
    i386:
    4fbf85314f748e70d688d4ef9f1ff039 lynx-2.8.5-11.1.i386.rpm
    
    x86_64:
    d5b28eee28b96bfc485c931bc70f6c8a lynx-2.8.5-11.1.x86_64.rpm
    
    
    Red Hat Enterprise Linux ES version 3:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/3ES/en/os/SRPMS/lynx-2.8.5-11.1.src.rpm
    ca0e6cecdbe5d962ba2e0e25906f06c3 lynx-2.8.5-11.1.src.rpm
    
    i386:
    4fbf85314f748e70d688d4ef9f1ff039 lynx-2.8.5-11.1.i386.rpm
    
    ia64:
    78719dbe540537935c8ff0580a2e0d81 lynx-2.8.5-11.1.ia64.rpm
    
    x86_64:
    d5b28eee28b96bfc485c931bc70f6c8a lynx-2.8.5-11.1.x86_64.rpm
    
    
    Red Hat Enterprise Linux WS version 3:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/3WS/en/os/SRPMS/lynx-2.8.5-11.1.src.rpm
    ca0e6cecdbe5d962ba2e0e25906f06c3 lynx-2.8.5-11.1.src.rpm
    
    i386:
    4fbf85314f748e70d688d4ef9f1ff039 lynx-2.8.5-11.1.i386.rpm
    
    ia64:
    78719dbe540537935c8ff0580a2e0d81 lynx-2.8.5-11.1.ia64.rpm
    
    x86_64:
    d5b28eee28b96bfc485c931bc70f6c8a lynx-2.8.5-11.1.x86_64.rpm
    
    
    Red Hat Enterprise Linux AS version 4:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/lynx-2.8.5-18.1.src.rpm
    ffba2de47eba8a232bc7105f5cbefd3d lynx-2.8.5-18.1.src.rpm
    
    i386:
    4513cdfc3723631c7782f6352cdc6b15 lynx-2.8.5-18.1.i386.rpm
    
    ia64:
    8e3a4b2cc33e6df7fef19930cc691989 lynx-2.8.5-18.1.ia64.rpm
    
    ppc:
    e6e33d53c3eca23c054c697b2c950bde lynx-2.8.5-18.1.ppc.rpm
    
    s390:
    03c82d440c67572bf89a32af3b736794 lynx-2.8.5-18.1.s390.rpm
    
    s390x:
    b6c47ed03460baeeab046340e937c857 lynx-2.8.5-18.1.s390x.rpm
    
    x86_64:
    02db15ab7e3205f8909e6f7e859f84f3 lynx-2.8.5-18.1.x86_64.rpm
    
    
    Red Hat Enterprise Linux Desktop version 4:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/lynx-2.8.5-18.1.src.rpm
    ffba2de47eba8a232bc7105f5cbefd3d lynx-2.8.5-18.1.src.rpm
    
    i386:
    4513cdfc3723631c7782f6352cdc6b15 lynx-2.8.5-18.1.i386.rpm
    
    x86_64:
    02db15ab7e3205f8909e6f7e859f84f3 lynx-2.8.5-18.1.x86_64.rpm
    
    
    Red Hat Enterprise Linux ES version 4:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/lynx-2.8.5-18.1.src.rpm
    
    ffba2de47eba8a232bc7105f5cbefd3d lynx-2.8.5-18.1.src.rpm
    
    i386:
    4513cdfc3723631c7782f6352cdc6b15 lynx-2.8.5-18.1.i386.rpm
    
    ia64:
    8e3a4b2cc33e6df7fef19930cc691989 lynx-2.8.5-18.1.ia64.rpm
    
    x86_64:
    02db15ab7e3205f8909e6f7e859f84f3 lynx-2.8.5-18.1.x86_64.rpm
    
    
    Red Hat Enterprise Linux WS version 4:
    
    SRPMS:
    ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/lynx-2.8.5-18.1.src.rpm
    ffba2de47eba8a232bc7105f5cbefd3d lynx-2.8.5-18.1.src.rpm
    
    i386:
    4513cdfc3723631c7782f6352cdc6b15 lynx-2.8.5-18.1.i386.rpm
    
    ia64:
    8e3a4b2cc33e6df7fef19930cc691989 lynx-2.8.5-18.1.ia64.rpm
    
    x86_64:
    02db15ab7e3205f8909e6f7e859f84f3 lynx-2.8.5-18.1.x86_64.rpm
    
  4. Apéndices

    Mayor información.

    http://rhn.redhat.com/errata/RHSA-2005-803.html
    http://www.seguridad.unam.mx/vulnerabilidadesDB/?vulne=4848

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Floriberto López Velázquez (flopez at seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Coordinación de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México Aviso legal |  Créditos |  Staff |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT