1 2 3 4 5 6

Vulnerabilidades rss pdf

Coordinación de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2005-514 Múltiples vulnerabilidades en ATutor.

Se reportarón varias vulnerabilidades en ATutor, que pueden explotarse para realizar ataques de Cross-site Scripting, obtener información sensible, y comprometer un sistema vulnerable.

  • Fecha de Liberación: 27-Oct-2005
  • Ultima Revisión: 27-Oct-2005
  • Fuente:

    Secunia Research Advisory.
    2005-55

  • Riesgo Altamente crítico
  • Problema de Vulnerabilidad Remoto
  • Tipo de Vulnerabilidad Verificación deficiente en parametros

Sistemas Afectados

ATutor 1.5.1-pl1
  1. Descripción

    Secunia Research reportó varias vulnerabilidades en ATutor, que pueden explotarse por personas maliciosas para realizar ataques de Cross-site Scripting, obtener información sensible, y comprometer un sistema vulnerable.

    1. La entrada que se pasa a los parámetros "addslashes", "asc" y "desc" dentro de "include/html/forum.inc.php" no es verificada apropiadamente antes de utilizarse para crear una llamad a función. Esto puede explotarse para llamar una función PHP arbitraria con parámetros arbitrarios (por ejemplo, ejecutar comandos de shell con la función "exec").

      Ejemplos:

      http://[host]/include/html/forum.inc.php?addslashes=[function]&asc=[parameter]
      http://[host]/include/html/forum.inc.php?addslashes=[function]&desc=[parameter]
      

      Una explotación exitosa requiere que "register_globals" este habilitado.

    2. La entrada que se pasa al parámetro "section" dentro de "body_header.inc.php" y "print.php" no es verificada aporpiadamente antes de utilizarse para incluir archivos. Esto puede explotarse para agregar archivos arbitrarios desde fuentes locales y externas.

      Ejemplos:

      http://[host]/documentation/common/body_header.inc.php?section=[file]%00
      http://[host]/documentation/common/print.php?section=[file]%00
      

      Una explotación exitosa requiere que "register_globals" este habilitado y que "magic_quotes_gpc" este deshabilitado.

    3. La entrada que se pasa al parámetro "_base_href" dentro de "admin/translate.php", al parámetro "_base_path" dentro de "include/html/editor_tabs/news.inc.php", y al parámetro "p" dentro de "documentation/add_note.php" no es verificada apropiadamente antes de regresarse al usuario. Esto puede explotarse para ejecutar scripts y código HTML arbitrarios dentro del navegador de un usuario en el contexto de un sitio afectado.

    Las vulnerabilidades se confirmarón en la versión 1.5.1-pl1. Otras versiones también podrían ser afectadas.

  2. Impacto

    Cross-site Scripting.

    Exposición de información sensible.

    Acceso al sistema.

  3. Solución

    Aplicar actualización.
    http://atutor.ca/view/3/6158/1.html

    Las correcciones también serán incluidas en la procima versión: 1.5.2.

  4. Apéndices

    Mayor información.

    http://secunia.com/secunia_research/2005-55/advisory/

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Floriberto López Velázquez (flopez at seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Coordinación de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México Aviso legal |  Créditos |  Staff |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT