1 2 3 4 5 6

Vulnerabilidades rss pdf

Coordinación de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2006-069 Múltiples vulnerabilidades en aplicación WLSE

Hay dos vulnerabilidades que existen en la tecnología de Cisco denominada CiscoWorks Wireless LAN Solution Engine (WLSE). La primera es una vulnerabilidad Cross Site Scripting (XSS) que podría permitir a un atacante obtener privilegios administrativos sobre el sistema. El segundo es una vulnerabilidad de tipo local en donde se puede realizar una escalación de privilegios, en la cual puede ser usada por un atacante quién ya se ha autenticado por medio de una interfaz de línea de comandos para obtener acceso al sistema operativo.

  • Fecha de Liberación: 21-Abr-2006
  • Ultima Revisión: 24-Abr-2006
  • Fuente: Cisco Systems
  • Riesgo Alto
  • Problema de Vulnerabilidad Local y remoto
  • Tipo de Vulnerabilidad Cross-Site Scripting

Sistemas Afectados

WLSE 2.13
  1. Descripción

    Hay dos vulnerabilidades que existen en la tecnología de Cisco denominada CiscoWorks Wireless LAN Solution Engine (WLSE). La primera es una vulnerabilidad Cross Site Scripting (XSS) que podría permitir a un atacante obtener privilegios administrativos sobre el sistema. El segundo es una vulnerabilidad de tipo local en donde se puede realizar una escalación de privilegios, en la cual puede ser usada por un atacante quién ya se ha autenticado por medio de una interfaz de línea de comandos para obtener acceso al sistema operativo.

    Cisco ha desarrollado aplicaciones gratuitas a disponibles a través de su sitio para estas vulnerabilidades que afectan a sus clientes. La advertencia está disponible en su sitio oficial

    CiscoWorks WLSE es una aplicación o sistemas de niveles centralizados para administrar y controlar una infraestructura autónoma de WLAN (Redes Wiress).

    Existen dos vulnerabilidades en dicha tecnología WLSE que podrían permitir a un atacante el obtener acceso y el control total de un dispositivo u obtener acceso directo al sistema operativo.

    Estas publicaciones están documentadas o descritas por el siguiente identificador de error de Cisco:

    • #CSCsc01095 ( sólo para usuarios registrados) -

      Vulnerabilidad Cross Site Scripting en la aplicación web (interfaz de administración) para administrar WLSE Esta corrección resuelve el problema de la vulnerabilidad Cross Site Scripting en la aplicación web (interfaz de administración) para administrar WLSE. Para corregir esta vulnerabilidad se pueden ubicar en el sitio oficial de Cisco. Al explotar esta vulnerabilidad, un atacante podría obtener la sesión y en un futuro utilizar esta información para poder obtener priviegios administrativos sobre el sistema.

    • #CSCsd21502(sólo para clientes registrados)

      - Privilegios para escalar privilegios en el Shell de Linux. Esta corrección resuelve la vulnerabilidad de poder escalar de forma local privilegios desde la línea de comandos a través de la interface de la aplicación WLSE appliance. Para explotar esta vulnerabilidad un atacante quién ya se ha autenticado por medio de la línea de comandos podría injectar un comando para obtener una cuenta de shell y así ganar acceso al sistema operativo.

  2. Impacto

    Al explotar estas vulnerabilidades en conkunto, un atacante podría obtener el acceso y control completo de la aplicación WLSE.

    Productos Vulnerables

    El producto CiscoWorks Wireless LAN Solution Engine (WLSE) o WLSE Express que ejecute alguna versión de software anterior a la 2.13 son vulnerables a dos de las vulnerabilidades ya antes mencionadas .

    Diversos productos de Cisco son afectados solo por la vulnerabilidad de escalación de privilegios de forma local, incluyéndo los siguientes productos : isco Hosting Solution Engine (HSE), Herramienta de Registro (User Registration Tool [URT]), Cisco Ethernet Subscriber Solution Engine (ESSE) y la herramienta CiscoWorks2000 Service Management Solution.

    Una respuesta de seguridad separada ha sido publicada al ver el imparto y las correcciones de esos productos, los cuales pueden ser encontrados en el mismo sitio oficial de cisco.

    Productos Confirmados como no vulnerables

    No hay otros productos de cisco que sean afectados por estas vulnerabilidades.

  3. Solución

    Cuando consideramos las actualizaciones de software, también podemos consultar http://www.cisco.com/go/psirt y algún aviso subsecuente para determinar la exposición y completa solución de actualización.

    En todos los casos, los clientes deben de ejercer precaución para estar seguros de los dispositivos a ser actualizados, para tener suficiente memoria y que las configuraciones de hardware y software actuales continuaran siendo soportadas adecuadamente por las nuevas versiones. Si la información no esta clara, contacte al Centro de Asistencia Técnica Cisco (:TAC") o a su proveedor de servisio para su asistencia.

    Estas vulnerabilidades son corregidas en la versión 2.13 version de la aplicación WLSE. Las correcciones u aplicaciones correctivas puenden ser descargadas de la siguiente dirección de internet http://www.cisco.com/pcgi-bin/tablebuild.pl/wlan-sol-eng

    Clientes con contratos de Servicio

    Para los clientes con contrato de servicio deben de obtener el software de actualización a través de su canal de actualización. Para muchos clientes, esto significa que las actualizaciones se deben de obtener a través del centro de Software de Cisco localizado en su sitio oficial

    .
    Clientes con soporte de terceras organizaciones

    Los clientes queines sus productos hayan sido provistos o mantenidos a través de un acuerdo con un tercero así como con los socios de Cisco, revendedores autorizados, o proveedores de servicio deben de contactar a la organización que da soporte para una correcta guia y asistencia para tomar apropiadamente accion con base a este aviso.

    La eficacia de alguna solución provicional o corrección depende de una situación específica de un cliente así como del producto, la topolgía de red, el comportamiento del tráfico, y la misión de la organizacional. Debido a la variedad de productos y publicaciones afectadas , los clientes deben consultar con sus respectivos proveedores de servicio o soporte para asegurar para asegurar la aplicación de una solución provicional o corregir de la forma más apropiada para su despliegue adecuado en la red.

    Clientes sin Contratos de Servicios
    Los clientes quienes compraron su producto directamente de Cisco pero no establecio un contrato de servicio y los cleintes queines compraron su producto a través de una tercera persona como los vendedores pero quienes no hayan podido obtener los parches a través de su punto de venta deen de obtener sus actualizaciones contactándo al Centro de Asistencia Técnica de Cisco (TAC). El cual tiene como contacto lo siguiente:
    1. +1 800 553 2447 (Llamada gratuita dentro de Norte America)
    2. +1 408 526 7209 (Llamada gratuita desde cualquier parte del mundo)
    3. e-mail: tac@cisco.com

    Tienes que dar el numero de serie de tú producto y la url de este aviso como evidencia para obtener actualizaciones de forma gratuita.

    Para actualizaciones para clientes que no tengan contrato de servicio deben de realizar la petición a través del TAC.

    Referirse a: http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml para información adicional de contacto del TAC, incluyéndo numeros especiales de localización e instrucciones y direcciones de correo electrónico para el uso en diversos lenguajes.

    Soluciones provisionales

    No hay soluciones provisionales para estas vulnerabilidades.

    Obteniendo las correcciones del software

    Cisco desarrollará aplicaciones correctivas disponibles en las direcciones para clientes afectados. Estas advertencias serán actualizadas como soluciones o aplicaciones correctivas que llegarán a estar disponibles. Más allá de del sofware, los cleintes deben de consultar a su proveedor de servicios o checar alguna característica de compatibilidad para obnener publicaciones específicas de su entorno.

    Los clientes podrían solo instalar y contar con el soporte para los sistemas que hayan comprado. Para instalar, descargar y accesar o sino utilizar un software de actualizaciones, los clientes tendrán que estar deacuerdo con los términos delicencia de Cisco que se encuentran en http://www.cisco.com/public/sw-license-agreement.html , o sino se pueden encontrar también en su sitio de descarga.

    De otra forma se puede contactar a psirt@cisco.com o security-alert@cisco.com para el software de actualización.

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Ricardo Carrillo Sanchez (rcarrillo at correo dot seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Coordinación de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México Aviso legal |  Créditos |  Staff |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT