1 2 3 4 5 6

Vulnerabilidades rss pdf

Coordinación de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2011-035 Vulnerabilidad en JScript y VBScript Scripting Engines que podrían permitir ejecución remota de código.

Esta actualización de seguridad resuelve una vulnerabilidad reportada de manera privada en JScript y VBScript Scripting Engines. La vulnerabilidad podría permitir ejecución remota de código si un usuario visita un sitio Web especialmente diseñado. Un atacante no tendría que forzar a los usuarios a visitar el sitio Web. En su lugar, el atacante tendría que convencer a los usuarios a visitar el sitio Web, por ejemplo, incitarles a hacer clic en un vínculo de un mensaje de correo electrónico o de mensajería instantánea que lleve a los usuarios al sitio web del atacante.

  • Fecha de Liberación: 12-Abr-2011
  • Ultima Revisión: 24-Abr-2011
  • Fuente: Microsoft Corp.
  • CVE ID: CVE-2011-0663
  • Riesgo Crítico
  • Problema de Vulnerabilidad Local y remoto
  • Tipo de Vulnerabilidad Ejecución remota de código

Sistemas Afectados

Microsoft Windows Windows Windows 7 for 32-bit Systems SP1, JScript 5.8 and VBScript 5.8 KB2475792
Microsoft Windows Windows Windows 7 for 32-bit Systems, JScript 5.8 and VBScript 5.8 KB2475792
Microsoft Windows Windows Windows 7 for x64-based Systems SP1, JScript 5.8 and VBScript 5.8 KB2475792
Microsoft Windows Windows Windows 7 for x64-based Systems, JScript 5.8 and VBScript 5.8 KB2475792
Microsoft Windows Windows Windows Server 2003 SP2, JScript 5.6 and VBScript 5.6 KB971961
Microsoft Windows Windows Windows Server 2003 SP2, JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows Server 2003 SP2, JScript 5.8 and VBScript 5.8 KB971961
Microsoft Windows Windows Windows Server 2003 with SP2 for Itanium-based Systems, JScript 5.6 and VBScript 5.6 KB971961
Microsoft Windows Windows Windows Server 2003 with SP2 for Itanium-based Systems, JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows Server 2003 x64 Edition SP2, JScript 5.6 and VBScript 5.6 KB971961
Microsoft Windows Windows Windows Server 2003 x64 Edition SP2, JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows Server 2003 x64 Edition SP2, JScript 5.8 and VBScript 5.8 KB971961
Microsoft Windows Windows Windows Server 2008 R2 for Itanium-based Systems SP1, JScript 5.8 and VBScript 5.8 KB2475792
Microsoft Windows Windows Windows Server 2008 R2 for Itanium-based Systems, JScript 5.8 and VBScript 5.8 KB971961
Microsoft Windows Windows Windows Server 2008 R2 for x64-based Systems SP1, JScript 5.8 and VBScript 5.8 KB2475792
Microsoft Windows Windows Windows Server 2008 R2 for x64-based Systems, JScript 5.8 and VBScript 5.8 KB2475792
Microsoft Windows Windows Windows Server 2008 for 32-bit Systems and Windows Server 2008 for 32-bit Systems SP2, JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows Server 2008 for 32-bit Systems and Windows Server 2008 for 32-bit Systems SP2, JScript 5.8 and VBScript 5.8 KB971961
Microsoft Windows Windows Windows Server 2008 for x64-based Systems and Windows Server 2008 for x64-based Systems SP2, JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows Server 2008 for x64-based Systems and Windows Server 2008 for x64-based Systems SP2, JScript 5.8 and VBScript 5.8 KB971961
Microsoft Windows Windows Windows Vista SP1 and Windows Vista SP2, JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows Vista SP1 and Windows Vista SP2,JScript 5.8 and VBScript 5.8 KB971961
Microsoft Windows Windows Windows Vista x64 Edition SP1 and Windows Vista x64 Edition SP2, JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows Vista x64 Edition SP1 and Windows Vista x64 Edition SP2, JScript 5.8 and VBScript 5.8[1] KB971961
Microsoft Windows Windows Windows XP Professional x64 Edition SP2, JScript 5.6 and VBScript 5.6 KB971961
Microsoft Windows Windows Windows XP Professional x64 Edition SP2, JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows XP Professional x64 Edition SP2,JScript 5.8 and VBScript 5.8 KB971961
Microsoft Windows Windows Windows XP SP3,JScript 5.7 and VBScript 5.7 KB971961
Microsoft Windows Windows Windows XP SP3,JScript 5.8 and VBScript 5.8 KB971961
  1. Software No Afectado

     

    A continuación se listará el software que no es afectado. Los componentes JScript 5.8 and VBScript 5.8 estan instalados en Intenet explorer 9.

    1. Windows Vista Service Pack 2
    2. Windows Vista x64 Edition Service Pack 2
    3. Windows Server 2008 for 32-bit Systems Service Pack 2
    4. Windows Server 2008 for x64-based Systems Service Pack 2
    5. Windows 7 for 32-bit Systems and Windows 7 for 32-bit Systems Service Pack 1
    6. Windows 7 for x64-based Systems and Windows 7 for x64-based Systems Service Pack 1
    7. Windows Server 2008 R2 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems Service Pack 1
    8. Windows Server 2008 R2 for Itanium-based Systems and Windows Server 2008 R2 for Itanium-based Systems Service Pack 1
  2. índice de explotabilidad

    1. Vulnerabilidad en la secuencia de comandos de la reasignación de memoria   CVE-2011-0663

    Código de explotación inconsistente

  3. Descripción

    1. Vulnerabilidad en la secuencia de comandos de la reasignación de memoria   CVE-2011-0663

    Una vulnerabilidad de ejecución remota de código existe en JScript y VBScript Scripting Engines debido a un error de corrupción de memoria.  

  4. Impacto

    1. Vulnerabilidad en la secuencia de comandos de la reasignación de memoria   CVE-2011-0663

    Un atacante que exitosamente explote esta vulnerabilidad podría ejecutar código arbitrario en el contexto del usuario conectado.
    Un atacante podría entonces instalar programas: ver, modificar, o borrar datos, crear nuevas cuentas con todos los derechos de usuario.

  5. Solución

    1. Windows XP Service Pack 3, JScript 5.7 and VBScript 5.7
    2. Windows XP Service Pack 3, JScript 5.8 and VBScript 5.8
    3. Windows XP Professional x64 Edition Service Pack 2, JScript 5.6 and VBScript 5.6JScript 5.7 and VBScript 5.7
    4. Windows XP Professional x64 Edition Service Pack 2, JScript 5.8 and VBScript 5.8
    5. Windows Server 2003 Service Pack 2, JScript 5.6 and VBScript 5.6JScript 5.7 and VBScript 5.7
    6. Windows Server 2003 Service Pack 2, JScript 5.8 and VBScript 5.8
    7. Windows Server 2003 x64 Edition Service Pack 2, JScript 5.6 and VBScript 5.6JScript 5.7 and VBScript 5.7
    8. Windows Server 2003 x64 Edition Service Pack 2, JScript 5.8 and VBScript 5.8
    9. Windows Server 2003 with SP2 for Itanium-based Systems, JScript 5.6 and VBScript 5.6JScript 5.7 and VBScript 5.7
    10. Windows Vista Service Pack 1 and Windows Vista Service Pack 2, JScript 5.7 and VBScript 5.7
    11. Windows Vista Service Pack 1 and Windows Vista Service Pack 2, JScript 5.8 and VBScript 5.8
    12. Windows Vista x64 Edition Service Pack 1 and Windows Vista x64 Edition Service Pack 2, JScript 5.7 and VBScript 5.7
    13. Windows Vista x64 Edition Service Pack 1 and Windows Vista x64 Edition Service Pack 2, JScript 5.8 and VBScript 5.8
    14. Windows Server 2008 for 32-bit Systems and Windows Server 2008 for 32-bit Systems Service Pack 2, JScript 5.7 and VBScript 5.7
    15. Windows Server 2008 for 32-bit Systems and Windows Server 2008 for 32-bit Systems Service Pack 2, JScript 5.8 and VBScript 5.8
    16. Windows Server 2008 for x64-based Systems and Windows Server 2008 for x64-based Systems Service Pack 2, JScript 5.7 and VBScript 5.7
    17. Windows Server 2008 for x64-based Systems and Windows Server 2008 for x64-based Systems Service Pack 2, JScript 5.8 and VBScript 5.8
    18. Windows Server 2008 for Itanium-based Systems and Windows Server 2008 for Itanium-based Systems Service Pack 2, JScript 5.7 and VBScript 5.7
    19. Windows 7 for 32-bit Systems, JScript 5.8 and VBScript 5.8
    20. Windows 7 for 32-bit Systems Service Pack 1, JScript 5.8 and VBScript 5.8
    21. Windows 7 for x64-based Systems, JScript 5.8 and VBScript 5.8
    22. Windows 7 for x64-based Systems Service Pack 1, JScript 5.8 and VBScript 5.8
    23. Windows Server 2008 R2 for x64-based Systems, JScript 5.8 and VBScript 5.8
    24. Windows Server 2008 R2 for x64-based Systems Service Pack 1, JScript 5.8 and VBScript 5.8
    25. Windows Server 2008 R2 for Itanium-based Systems, JScript 5.8 and VBScript 5.8
    26. Windows Server 2008 R2 for Itanium-based Systems Service Pack 1, JScript 5.8 and VBScript 5.8

     

     

     

  6. Referencias

    1. http://www.microsoft.com/technet/security/bulletin/ms11-apr.mspx
    2. http://www.microsoft.com/technet/security/Bulletin/MS11-031.mspx

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Mayra Villeda (mvilleda at seguridad dot unam dot mx)
  • Manuel Ignacio Quintero Martínez (mquintero at seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Coordinación de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México Aviso legal |  Créditos |  Staff |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT